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warstw czy innych zaawansowanych narzędzi programu. Całość, 
za pomocą polecenia Save For Web & Devices, zostanie zapisana 
w postaci prostego banera GIF a wszystkie wykorzystane obiekty 
pozostaną spłaszczone do jednej warstwy.

wprowadzenie i formatowanie tekstów
Kolejny krok to wprowadzenie właściwych tekstów. Za pomocą 
narzędzia Horizontal Type Tool [T] wprowadzamy nazwę przykła-
dowego miasta (Rysunek 3.). O ile to konieczne, dobieramy odpo-
wiedni kolor, krój i wielkość tekstu. Co ważne, w tym miejscu nic 
nie stoi na przeszkodzie, by wprowadzony tekst poddać dodatko-
wej edycji. Za pomocą narzędzi transformacji (Rotation, Warp) 
czy też stylów warstw (Drop Shadow, Bevel&Emboss, Stroke itp.) 
nadajemy naszej pracy ostateczną postać. 

W podobny sposób dodajemy i formatujemy drugi tekst z da-
tą konkretnego wydarzenia. Naturalnie oba teksty zapisane są 
na oddzielnych warstwach tekstowych (Rysunek 4.).

tworzenie zmiennych tekstowych
Aby wykonać serię banerów na podstawie przygotowanego pro-
jektu, konieczne jest zdefiniowanie zmiennych, które pozwolą 
na prezentację nazw kolejnych lokalizacji oraz terminów imprezy 
w ustalonych miejscach. 

W tym celu zaznaczamy pierwszą warstwę tekstową z wi-
doczną nazwą miasta i za pomocą polecenia Image>Variable-
s>Define przekształcamy ją w zmienną (variable). W oknie dia-
logowym Variables konieczne jest wprowadzenie kilku istotnych 
zmian. W sekcji Layer upewniamy się, że wybrana jest właściwa 
warstwa tekstowa, a następnie zaznaczamy opcję Text Replace-
ment i w aktywowanym w ten sposób polu Name wprowadzamy 
nazwę zmiennej – miasto (Rysunek 5.). Następnie za pomocą 
przycisku OK, potwierdzamy wprowadzone właśnie ustawienia. 

W podobny sposób zaznaczamy drugą warstwę tekstową 
– datę i za pomocą polecenia Image>Variables>Define tworzymy 
kolejną zmienną typu Text Replacement, o nazwie – data (Rysu-
nek 6.).

banery WWW 
tworzone na podstawie zmiennych

Jeśli zdarzyło Ci się przygotować kilkanaście, czy nawet kilka-
dziesiąt banerów reklamowych na podstawie jednego projektu 
graficznego (Rysunek 1.). Z pewnością dobrze wiesz, jak nudna 
to i niewdzięczna praca. Mimo że, wprowadzanie jedynie drob-
nych zmian w tekstach reklamowych czy datach nie jest być mo-
że wielce skomplikowanym działaniem, jest jednak niezwykle 
monotonne i zwykle zabiera wiele cennego czasu. 

Możemy to jednak łatwo i szybko zmienić. Dzięki użyciu 
Photoshopa jesteśmy w stanie szybko i całkowicie automatycz-
nie przygotować setki grafik, czy właśnie banerów interneto-
wych opartych o jeden projekt graficzny, używając w tym ce-
lu zewnętrznych zmiennych. Zapisane w pliku tekstowym dane 
można łatwo edytować za pomocą najprostszych edytorów tek-
stu np. Notatnika, a proces ich przygotowania i użycia w prakty-
ce nie jest szczególnie trudny.

założenia ogólne – kampania reklamowa
Wyobraźmy sobie następującą sytuację. Przygotowujemy wła-
śnie ogólnopolską kampanię reklamową ciekawego wydarzenia 
sportowego, które odbywać się będzie w wielu miastach Polski. 
Naturalnie, w tej sytuacji, konieczne będzie przygotowanie bane-
rów informacyjnych wraz z datą oraz lokalizacją imprezy dla każ-
dego miasta osobno. Oczywiście, pomimo tworzenia osobnych 
reklam, wykorzystamy tu jeden wspólny projekt graficzny oraz 
dane tekstowe, zapisane w zewnętrznym pliku. 

Podczas projektowania reklamy ważne jest, aby przygoto-
wać dobrą strukturę całego projektu. Kolejne miasta oraz daty 
prezentowane będą zawsze w tym samym miejscu. Musimy więc 
przygotować odpowiednio dużo miejsca na wprowadzanie nawet 
najdłuższych nazw miast, a także dat. W całej pracy zmieniamy 
jedynie zawartość tekstową, bez ingerencji w układ graficzny, 
toteż dobry projekt ułatwi nam w pełni automatyczne działania. 
Zatem do dzieła.

przygotowanie szablonu graficznego banera
Pracę nad banerem rozpoczynamy od przygotowania prostego 
projektu graficznego. Możemy to zrobić za pomocą Photoshopa 
jak również za pomocą dowolnego innego programu graficznego. 
W tym przypadku wykorzystałem prosty układ graficzny, oparty 
na kilku elementach graficznych zbudowanych w programie Ado-
be Illustrator CS3. Zarówno postać, jak i elementy tła utworzo-
ne zostały za pomocą funkcji Live Trace, czyli automatycznego 
przekształcania elementów bitmapowych w wektorowe. Dodałem 
także nowy, bardziej wyrazisty kolor tła, tekstowe logo oraz nie-
wielki tekst z adresem strony internetowej naszej hipotetycznej 
imprezy (Rysunek 2.).

Naturalnie, do budowy projektu banera, wykorzystać może-
my także wszystkie narzędzia dostępne w programie Adobe Pho-
toshop. Nie będzie żadnych problemów z użyciem masek, stylów 

W poniższym artykule poznamy sekrety budowy internetowej kampanii 
reklamowej za pomocą programu Adobe Photoshop, oraz zewnętrznych 
zmiennych tekstowych.

Rysunek 1. Seria banerów reklamowych budowanych na pod-
stawie staego projektu graficznego i zmiany danych tekstowych
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W rezultacie, mamy już gotowe wszystkie elementy gra-
ficzne oraz zdefiniowane konieczne zmienne. Zapisujemy ro-
boczy dokument w formacie PSD, w dowolnej lokalizacji na 
naszym dysku. Kolejny istotny krok to utworzenie pliku teksto-
wego, zawierającego dane o wszystkich lokalizacjach oraz ter-
minach imprezy.

budujemy zewnętrzny plik danych
Do budowy pliku danych możemy wykorzystać najprostszy edy-
tor tekstu. Doskonale sprawdza się tu nawet popularny Notatnik 
Windows lub TextEdit Maca. Aby dane zostały poprawnie interpre-
towane przez Photoshopa, konieczne jest zachowanie specjalnej 
struktury pliku. Musi być on skonstruowany dokładnie na pod-
stawie następującego schematu:

•  nazwa zmiennej nazwa zmiennej nazwa zmiennej
•  wartość zmiennej wartość zmiennej wartość zmiennej
•  wartość zmiennej 2 wartość zmiennej 2 wartość zmiennej 2
•  wartość zmiennej n wartość zmiennej n wartość zmiennej n

Co ważne, nie należy w żaden specjalny sposób formatować da-
nych, powinien to być jedynie prosty tekst z konkretnymi dany-
mi, rozdzielanymi za pomocą tabulatora. W naszym przypadku 
kolejne pary zmiennych (miasto i data) wprowadzamy w nowych 
wierszach i oddzielamy tabulatorem (Rysunek 7.).

Przykład pliku danych dla naszej pracy mógłby wyglądać 
w następujący sposób:

Miasto data
Warszawa 23 maja 2008 Stadion Gwardii
Poznań 24 maja 2008 Arena
Katowice 26 maja 2008 Spodek
Jelenia Góra 27 maja 2008 Stadion miejski

Wprowadzając dane w pliku tekstowym, ważne jest, aby pamię-
tać o kilku drobnych szczegółach:

•  kolumna danych musi odpowiadać nazwie zmiennej dla da-
nej kolumny,

•  muszą być zdefiniowane wszystkie zmienne, nie można po-
zostawić pustego miejsca w kolumnie z danymi.

Gotowy plik tekstowy zapisujemy w dowolnej lokalizacji na naszym 
dysku. Naturalnie byłoby bardzo wygodnie zapisać go w tym sa-
mym katalogu, co przygotowany wcześniej plik PSD Photoshopa.

wykorzystanie zmiennych w Photoshopie
Przygotowany plik danych wykorzystamy niebawem do automa-
tycznego utworzenia serii banerów reklamowych. Wcześniej jed-

nak, musimy wczytać wszystkie zmienne do przygotowanego 
wcześniej projektu w pliku PSD. 

Wykorzystamy w tym celu polecenie Data Sets dostępne 
w menu górnym Image>Variables>Data Sets. Początkowo, w wy-
świetlonym oknie dialogowym Data Sets niedostępne są wszel-

Rysunek 2. Do budowy naszej reklamy moemy wykorzysta do-
wolny program graficzny oraz dowolne narzdzia Photoshopa

Rysunek 3. Za pomoc narzdzia Horizontal Type Tool [T] wpro-
wadzamy nazw przykadowego miasta

Rysunek 4. Wprowadzamy przykadowe dane i nadajemy tek-
stom odpowiedni wygld. Wane jest, aby teksty zapisa na dwóch 
oddzielnych warstwach

Rysunek 5. W sekcji Layer upewniamy si, e wybrana jest 
waciwa warstwa tekstowa, a nastpnie zaznaczamy opcj Text 
Replacement i w aktywowanym w ten sposób polu Name wprowa-
dzamy nazw zmiennej – miasto

Rysunek 6. W podobny sposób tworzymy kolejn zmienn typu 
Text Replacement o nazwie – data

Rysunek 7. (Co wane, nie naley w aden specjalny sposób for-
matowa danych, powinien to by jedynie prosty tekst z konkretny-
mi danymi, rozdzielanymi przecinkami lub za pomoc tabulatora)
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Bezpośrednio po wczytaniu zewnętrznych zmiennych akty-
wują się opcje okna Data Sets, co umożliwia nam podjęcie kolej-
nych działań. 

W dolnej sekcji okna widoczne są wszystkie zdefiniowa-
ne wcześniej zmienne (Rysunek 10.). W tym przypadku będą to 
odpowiednio: miasto oraz data. Dzięki uruchomieniu podglądu, 
pierwszy zestaw wczytanych danych od razu widoczny jest tak-
że w oknie dokumentu Photoshopa. Za pomocą niewielkich strza-
łek w sekcji Data Set możliwy jest podgląd kolejnych par zmien-
nych. Naturalnie, każda wczytana para odpowiednio przekształco-
na i formatowana, jest od razu widoczna w oknie naszego projek-
tu (Rysunek 11.).

Nawet już po zamknięciu okna Data Sets można łatwo zmie-
niać zestaw danych, za pomocą palety Apply Data Sets dostęp-
nej w menu górnym Image>Apply Data Set (Rysunek 12.). W tym 
miejscu, po uruchomieniu podglądu, możliwe jest szybkie wy-
szukanie odpowiedniego zestawu danych i zapis w osobnym pli-
ku graficznym.

To całkiem wygodne, import i podgląd danych z pliku ze-
wnętrznego działa bez zarzutu, jednak co w sytuacji, gdy danych 

kie opcje, dotyczące obsługi zmiennych (Rysunek 8.). Nie jest to 
jednak żaden problem; wkrótce ulegnie on całkowitej zmianie. Dla 
wygody uruchamiamy od razu podgląd (przycisk Preview), a na-
stępnie za pomocą przycisku Import wczytujemy dane zapisane 
w przygotowanym pliku tekstowym. Jeśli korzystamy z Photoshopa 
CS3, nie ma konieczności, by w oknie importu wprowadzać jakiekol-
wiek zmiany (Rysunek 9.). Kodowanie tekstu zostanie automatycz-
nie rozpoznane i właściwie interpretowane przez Photoshopa.

Rysunek 8. Aby wczyta zmienne do przygotowanego wczeniej 
projektu w pliku PSD, wykorzystamy plecenie Data Sets dostpne 
w menu górnym Image>Variables>Data Sets

Rysunek 9. W oknie importu danych nie ma konieczno-
ci wprowadzania jakichkolwiek zmian. Kodowanie tekstu zosta-
nie automatycznie rozpoznane i waciwie interpretowane przez 
Photoshopa

Rysunek 10. W dolnej sekcji okna widoczne s wszystkie zdefi-
niowane wczeniej zmienne. W tym przypadku bd to odpowiednio: 
miasto oraz data

Rysunek 11. Kada wczytana para zmiennych, odpowiednio 
przeksztacona i formatowana, jest od razu widoczna w oknie na-
szego projektu

Rysunek 12. Nawet ju po zamkniciu okna Data Sets mona atwo 
zmienia zestaw danych, za pomoc palety Apply Data Sets dostp-
nej w menu górnym Image>Apply Data Set

Rysunek 13. Za pomoc polecenia File>Export>Data Sets as 
Files otwieramy okno dialogowe – Export Data Sets as Files
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zewnętrznych mamy kilkanaście lub nawet więcej. Zapis kolej-
nych plików z odpowiednim zestawem danych byłby strasznie 
nudnym i żmudnym procesem. Spróbujmy więc nieco zautoma-
tyzować ów proces.

eksport – Automatyczne tworzenie 
serii banerów reklamowych
Gdy wszystkie zewnętrzne dane są poprawnie ładowane do pliku 
Photoshopa, możliwe jest użycie automatycznych narzędzi, któ-
re pomogą szybko zapisać serię banerów internetowych. Za po-
mocą polecenia File>Export>Data Sets as Files otwieramy cieka-
we okno dialogowe – Export Data Sets as Files (Rysunek 13.).

Za pomocą przycisku Save Folder w sekcji Save Options 
wskazujemy miejsce docelowe, gdzie zostaną zapisane wszyst-
kie pliki wynikowe naszej serii. Dodatkowo, w polu poniżej, wy-
bieram jaki zestaw danych chcielibyśmy wyeksportować. Najwy-
godniej zadziała tu opcja All Data Sets, która pozwoli mi na zapis 
serii banerów budowanych, na podstawie wszystkich zestawów 
(Data Sets) zmiennych.

W sekcji File Naming możliwe jest określenie wybranego 
sposobu nazywania plików wynikowych. Co istotne, jako podsta-
wę nazwy pliku graficznego, mogę w tym miejscu wskazać jed-
ną ze zmiennych, by w ten sposób różnicować produkty. Natu-
ralnie, w przypadku, gdyby odpowiadały mi bardziej jednorod-
ne nazwy, nie muszę korzystać ze zmiennych podczas określa-
nia nazw plików.

No cóż, po wciśnięciu przycisku OK, nie pozostaje mi nic in-
nego, jak radować się nową, wspaniałą funkcją programu, która 
w wielu przypadkach pozwoli zaoszczędzić naprawdę dużo, zwy-
kle cennego czasu. 

uwaga!
Jest tu jednak pewien problem, wszystkie banery eksportowa-
ne są do pliku PSD, który niezbyt dobrze sprawdza się w zasto-
sowaniach internetowych. Do prezentacji na stronie interneto-
wej konieczna jest jego konwersja na postać GIF lub JPEG w za-
leżności od potrzeb (Rysunek 14.). Naturalnie tą prostą opera-
cję możemy wykonać, używając panelu Actions i przygotowa-
nej akcji. 

Paweł Zakrzewski
Adobe Certified Expert

Adobe Certified Instructor

Rysunek 14. Dziki uyciu wasnej akcji moliwe jest przekonwer-
towanie przygotowanych wczeniej banerów PSD do formatu GIF 
lub JPEG


